• CISCO COMMAND LINE (Perintah text cisco)




    Berikut ini daftar perintah dasar yang sering digunakan dalam mode CLI (Command Line)
    1. Setting Password
    router>enable
    router#configure terminal
    router(config)#enable password forumsains (set password untuk masuk ke mode privilege)
    router(config)#enable secret secret (set enkripsi untuk password yang disimpan)

    2. Setting Host Name
    router>enable
    router#configure terminal
    router(config)#hostname nama-host

    3. Setting VLAN
    router>enable
    router#configure terminal
    router(config)#vlan nomor-vlan
    router(config-vlan)#name nama-vlan

    4. Setting IP Address pada VLAN
    router>enable
    router#configure terminal
    router(config)#interface vlan 1
    router(config-if)#ip address address mask (misal: ip address 172.10.46.1 255.255.255.0)
    router(config-if)#no shutdown
    5. Setting Identitas pada Port Cisco Catalystrouter>enable
    router#configure terminal
    router(config)#interface nama-port
    router(config-if)#description “Port Setting Identitas”
    router(config-if)#end
    6. Setting IP Gatewayrouter>enable
    router#configure terminal
    router(config)#ip default-gateway address

    7. Setting Port-Speed dan Link-Mode
    router#configure terminal
    router(config)#interface nama-port (misal : interface fast ethernet 0/1)
    router(config-if)#speed 100
    router(config-if)#duplex full
    router#configure terminal
    router(config)#interface nama-port
    router(config-if)#switchport mode access
    router(config-if)#switchport access vlan nama-vlan
    router#configure terminal
    router(config)#interface nama-port
    router(config-if)#switchport mode trunk
    router(config-if)#switchport trunk allowed vlan nama-vlan

    8. Setting Line VTY
    router#configure terminal
    router(config)#line vty 0 4
    router(config-line)#login
    router(config-line)#password password

    9. Setting Line Con 0
    router#configure terminal
    router(config)#line con 0
    router(config-line)#login
    router(config-line)#password password

    10. Melihat Semua Konfigurasi
    router#show running-config

    11. Menghapus Semua Konfigurasi
    router#erase startup-config
    router#dir
    router#delete flash:vlan.dat
    router#dir
    router#reload
    Command pada router cisco devices terdiri dari Router Commands

    CISCO ROUTER COMMANDS :
    Usermode Commands
    1. disconnect, hapus sesi telnet dan logout
    2. enable, masuk ke privilegemode
    3. ping
    4. traceroute
    Privilegemode Commands
    1. clear arp-cache, hapus cache arp
    2. configure terminal, masuk ke global configuration mode
    3. copy running-config startup-config, simpan konfigurasi sekarang
    4. copy startup-config running-config, load konfigurasi yang tersimpan
    5. debug ip packet, debug paket dari tcp/ip
    6. disable, kembali ke privilegemode dari global configuration mode
    7. disconnect
    8. erase startup-config, hapus file konfigurasi dari router
    9. logout, keluar dari privilegemode
    10. ping
    11. reload, load kembali startup-config
    12. resume , konek kembali setelah diskonek13. show access-list, memperlihatkan semua access-list dari semua
    protokol pada router
    14. show banner, memperlihatkan banner
    15. show cdp, memperlihatkan status CDP router
    16. show cdp interface, memperlihatkan interface CDP
    17. show cdp neighbor
    18. show cdp traffic
    19. show clock
    20. show flash, memperlihatkan IOS image dan file yang tersimpan di flash
    memory
    21. show frame-relay lmi, memperlihatkan statistik detail LMI
    22. show frame-relay map
    23. show frame-relay pvc
    24. show history, memperlihatkan semua perintah yang telah dieksekusi
    25. show hosts, memperlihatkan static host yang disimpan
    26. show interfaces, memperlihatkan interface yang dimiliki (semua)
    secara detail
    27. show interfaces ethernet 0
    28. show interfaces serial 0
    29. show interfaces loopback 0
    30. show ip arp
    31. show ip eigrp neighbors
    32. show ip eigrp neighbors detail
    33. show ip eigrp topology
    34. show ip eigrp traffic, memperlihatkan traffic statistik dari protokol eigrp
    35. show ip interface
    36. show ip interface brief, verify konfigurasi ip
    37. show ip ospf database
    38. show ip ospf interface
    39. show ip ospf neighbor detail
    40. show ip route, memperlihatkan konfigurasi routing
    41. show protocols, memperlihatkan protokol routing yang telah dikonfigurasi dan
    sedang berjalan
    42. show running-config, memperlihatkan konfigurasi global yang sedang berjalan
    43. show sessions, memperlihatkan sesi yang ada sekarang
    44. show startup-config, memperlihatkan konfigurasi yang tersimpan pada flash
    45. show version, memperlihatkan informasi hardware dan firmware
    46. telnet
    47. traceroute
    48. vlan database, mengakses vlan database atau masuk ke konfigurasi VTP
    49. write erase
    50. write memory
    51. write terminal
    Global configuration mode Commands
    1. access-list {permit|deny}
    2. access-list {permit|deny}
    3. access-list {permit|deny}
    4. access-list {permit|deny}
    5. banner motd
    6. cdp advertise-v2
    7. cdp holdtime , mengubah nilai holdtime cdp8. cdp run
    9. cdp timer , mengubah nilai cdp timer10. config-register
    11. dialer-list protocol ip permit12. enable password , set password untuk masuk kemode privilege
    13. enable secret , set enkripsi untuk password yang disimpan14. end, kembali ke mode privilege
    15. hostname , set nama host16. interface ethernet 0, masuk ke subconfiguration interface ethernet 0
    17. interface fastethernet 0, masuk ke subconfiguration interface fastethernet 0
    18. interface serial 0, masuk ke subconfiguration interface serial 0
    19. interface vlan , masuk ke subconfiguration vlan20. ip default-gateway , set default gateway21. ip default-network
    22. ip host , set static hostname lain23. ip name-server , set DNS router24. ip route {next-hop-ip-addr|interface-type}25. ip route 0.0.0.0 0.0.0.0 , set defaut gateway / static route26. ip route , set static route27. ip routing
    28. ipx routing
    29. isdn switch-type
    30. line aux
    31. line console 0, masuk ke konfigurasi console nomer 0
    32. line vty 0 4, masuk ke konfigurasi vty untuk 5 buah vty
    33. no banner motd, menghapus banner
    34. no ip routing, menghapus ip routing
    35. no router igrp, menghapus konfigurasi route igrp
    36. no router ospf, menghapus konfigurasi route ospf
    37. no router rip, menghapus konfigurasi route rip
    38. no vlan , menghapus vlan nomer ke sekian39. router eigrp , masuk ke konfigurasi routing menggunakan eigrp40. router ospf , masuk ke konfigurasi routing menggunakan ospf41. router rip, masuk ke konfigurasi routing menggunakan rip
    42. snmp-server enable traps vtp
    43. username password , set username danpasswordnya
    Interface subconfiguration mode Commands
    1. bandwidth , set bandwidth yang akan dilalui interfaceini dalam kilobits
    2. cdp enable
    3. clock rate , set clock rate dalam bits/s4. compress stac in
    Line subconfiguration mode Commands
    1. exec-timeout [detik], pilihan detik opsional2. login synchronous
    3. password , set passwordnya
    Subinterface subconfiguration mode Commands
    1. description , set deskripsi dari subinterfaceIP Routing Protocol subconfiguration mode Commands
    1. network , set ip networkContoh :
    Lab_A>enable
    Lab_A#configure terminal atau config t
    Lab_A(router)#interface fast eth0/0 atau int f0/0
    Lab_A(router-config)#ip add 192.168.0.2 255.255.255.0 (misal)
    Lab_A(router-config)#no shut (mengaktifkan Network IP kayak service
    network restart kalo di linux)
    Lab_A(router-config)#end
    Lab_A#show ip interface brief ( melihat configurasi IP yg telah diseting )
  • You might also like

    No comments:

    Post a Comment

my blog. Powered by Blogger.

Recent

Comment